Topics

Dropping support for Python 2.7 in rasterio 1.1.0

Sean Gillies
 

Hi all,

We've got a proposal to drop support for Python 2.7 at version 1.1.0 (see https://github.com/mapbox/rasterio/issues/1613). I want to bring it up for discussion here now.

Numpy 1.17.0 won't support 2.7 and will do what it can to prohibit us from installing it with 2.7. Since Numpy is one of our biggest dependencies, the issue has to be addressed. If we want to support 2.7, we'll have to pin Numpy to 1.16 and forgo future improvements. I'm in favor of dropping support for 2.7 so that we can continue working with the latest and greatest Numpy, not to mention eliminating old compatibility code within rasterio.

What does it mean to drop support? We'll remove 2.7 from the CI build matrices. We will add `python_requires = '>=3.5'` to our setup script. We will publish no more wheels for 2.7.

Any objections?

Alan Snow
 

Sounds like a good plan to me πŸ‘

Erik Seglem
 

At this point I am always in favor of dropping anything less than 3.5. Especially in this case whenΒ  keeping numpy support is important. While it might take some work to clear out the compatibility code, it will be worth it in the end and hopefully make the code cleaner.

vincent.sarago@...
 

+1 πŸŽ‰

Sean Gillies
 

Thanks for the feedback. Looks like we have consensus.


On Mon, May 13, 2019 at 6:31 PM <vincent.sarago@...> wrote:
+1 πŸŽ‰



--
Sean Gillies