Topics

Numpy Python Support Cadence

Alan Snow
 

I recently noticed this issue where xarray is dropping python 3.5 support due to numpy's recommended cadence in python support:

https://github.com/pydata/xarray/issues/3293

numpy support schedule:

https://numpy.org/neps/nep-0029-deprecation_policy.html

I am curious how this will impact rasterio.

Sean Gillies
 

Alan,

Thanks for bringing this up. I could get behind this. Rasterio uses semantic versioning like the other projects downstream of numpy and so we can use the drop schedule published in that doc.



On Thu, Oct 17, 2019 at 5:53 PM Alan Snow <alansnow21@...> wrote:
I recently noticed this issue where xarray is dropping python 3.5 support due to numpy's recommended cadence in python support:

https://github.com/pydata/xarray/issues/3293

numpy support schedule:

https://numpy.org/neps/nep-0029-deprecation_policy.html

I am curious how this will impact rasterio.



--
Sean Gillies