Re: Rasterio 1.0.3.post1


Sean Gillies
 

Even,

Thanks for the pointer!

In configuring my GDAL 2.3.1 builds, pkg-config and openjpeg were found:
checking for pkg-config... (cached) /usr/local/bin/pkg-config
checking pkg-config is at least version 0.25... yes
checking for OPENJPEG... yes
checking for opj_setup_decoder in -lopenjp2... yes

(full logs here:

and I'm able to open GDAL's jp2 test files with the 1.0.3.post1 wheel (for python 3.6 and OSX).

Denis, I think your issue is different than the one I've reported here. What's your operating system and did you install from the sdist or install a binary wheel?

On Mon, Sep 10, 2018 at 12:17 PM Even Rouault <even.rouault@...> wrote:
On lundi 10 septembre 2018 14:29:39 CEST Sean Gillies wrote:
> Thanks for the report, Denis. I had upgraded GDAL to 2.3.1 in these wheel
> builds, and was blaming my inability to access these jp2 files on a lack of
> credentials, but maybe something has changed between Rasterio and JP2 in
> 2.3.0? I'm going to revert to 2.2.4, the version in the 1.0.2 wheels.

Sean,

Your wheels use openjpeg for GDAL JPEG2000 capability, right ? There has been
a change in GDAL ./configure in 2.3.0 related to openjpeg detection. It now
requires pkg-config to be available to detect openjpeg.

Even


--
Sean Gillies

Join main@rasterio.groups.io to automatically receive all group messages.