Re: Rasterio 1.0.3 and Python 3.4


Sean Gillies
 

Hi Denis,

Since we switched over to making  wheels using the multibuild project we're blocked from releasing *well tested* Python 3.4 linux wheels by (my hypothesis) bugs in trusty's python 3.4.3. The issue is described here: https://github.com/sgillies/rasterio-wheels/issues/5.

I'm short on time to solve this problem, but there are 2 solid workarounds:

1) build and install rasterio from source `GDAL_CONFIG=path/to/gdal-config pip install rasterio` (requires build-essential, gdal-dev, other system packages).
2) switch to Python 3.5 or 3.6 from the deadsnakes PPA and then `pip install rasterio` to get a wheel for one of those versions.


On Fri, Sep 28, 2018 at 9:38 AM Denis Rykov <rykovd@...> wrote:
There is no Linux wheel for Python 3.4 here: https://pypi.org/project/rasterio/#files



--
Sean Gillies

Join main@rasterio.groups.io to automatically receive all group messages.